Server Offline

Incident Report for TheosWorld

Resolved

This incident has been resolved.
Posted Sep 17, 2026 - 00:41 UTC

Monitoring

The Server is currently offline for software updates. Sorry for any inconvenience!
Posted Sep 16, 2026 - 23:13 UTC
This incident affected: DPL (DPL Site, DPL Library Staff Portal, DPL Holds System, DPL Staff Clock, DPL Staff holds Management, DPL Email Alerts System, DPL Kiosk Backend) and Website DNS.